10
2014
02

ros做PPPOE服务器时自动绑定客户端MAC地址

/ppp secret;:foreach pppuser in [find caller-id=""] do={:local user [get $pppuser name];/ppp active:foreach pact in [find name=$user] do={:local mac [get $pact caller-id];/ppp secret set [/ppp secret find name=$user] caller-id=$mac;}}绑定所有正在
04
2014
01

radius中导出的CSV文件转换成Excel文件

最近在使用Radius Manager 4.0.4,想要将radius中的用户信息导出,但radius本身提供CSV文本输出,并不是想要的Excel表格样式,现提供转换方法。 导出的csv文件可以直接用记事本,excel打开;用记事本或excel打开的时候,是用分号隔开的,而且excel打开的时候会有乱码。 在简体中文环境下,EXCEL打开的CSV文件默认是ANSI编码,如果CSV文件的编码方式为utf-8、Unicode等编码可能就会出现文件乱码的情况。解决方法:先用记事本
07
2013
12

RouterOS备份系统到163邮箱

在System->Scheduler里,添加一个Scheduler::global mailip:set mailip [:resolve smtp.163.com]:global mailuser “XXX”:global mailpw “XXX”:global Tomail “XXX8@163.com”/tool e-mail set from=XXX@163.com address=$mailip user=$mailuser password=$mailpw port=25/exp
01
2013
11

changeip.com改版后RouterOS(ROS)设置动态域名(DDNS)

使用DDNS把动态IP地址映射到一个固定的域名解析服务上,用户每次连接网络的时候客户端程序通过信息传递把该主机的动态IP地址传送给服务器程序,服务项目程序提供DNS服务并实现动态域名解析。添加一个Scheduler,system->Scheduler::global ddnsiptemp [/ip addres get [/ip address find interface=pppoe-out1] address ]:global ddnsip [:pick $ddnsiptemp 0 [
05
2013
07

ROS 2ADSL双线负载均衡

本次列出使用PCC负载均衡实例网上看到过教程,感觉脚本来的快点,下面就是PCC2个ADSL的负载均衡的脚本:/ip firewall mangleadd action=mark-connection chain=prerouting disabled=no new-connection-mark=1 \passthrough=yes per-connection-classifier=both-addresses:2/0 src-address=\10.20.20.0/24add action=
05
2013
07

ROS做PPPoE服务器教程

一、创建 PPPoE servera、进入winbox,点击 主菜单 最上面的PPP再点击 “Interfaces”,弹出的“Interface list”对话框中依次点击“settings”-“PPPoE Server”,b、这时弹出“PPPoE Server list”对话框,点击左边的“+”号,“Interface”选项里选择 内网网卡,选中 “One session Per Host”,按 OK。二、创建 IP 地址池a、点击 主菜单 中的 “IP – Pool”b、点击“+”号,在出现
04
2013
07

ROS L4-L6授权表(ROS等级功能区别)

01
2013
07

ros配置DMZ(端口映射)

简单的说,当我们内网服务器的所有端口都需要开放到外网的时候,我们需要使用DMZ功能。本文将演示如何将内网IP:10.10.10.2的所有端口映射,开放到公网。操作路径:ip-firewall-NAT:可以分多条处理比如TCP和UDP协议分开处理,如果8291用于管理ROS的话也要考虑。
01
2013
07

ROS屏蔽某个网站

脚本示例:/ip firewall filter add chain=forward content="baidu.com" action=dropcomment="drop-baidu" disabled=no*以上脚本屏蔽baidu.com的连接。其它域名照做即可。Winbox操作示例(进入Winbox,打开IP-firewall-filter):
01
2013
07

ROS设置自动重启

每隔7天在05:30重启ROS:/system scheduler add name="Timing ReBoot" on-event="/system reboot"start-date=Jan/01/1990 start-time="05:30:00" interval="7d 00:00:00"comment="B6A8CAB1D6D8C6F4" disabled=no*interval定义